summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-08-14 09:33:07 -0700
committerDylan Baker <dylan@pnwbakers.com>2018-08-16 13:51:44 -0700
commit5a8f824d8c3feabd73be6b10c8efebd19120d822 (patch)
tree9a607fdaedffbd16e856dbd3b616a83e12db4561 /meson.build
parent52194ae4df18c7211cef69354a686eabc297a18d (diff)
meson: use python3 module to find python3
This handy helper is nice for OSes that are not linux or BSD like (mac and windows) as it knows how to find python3 in odd places. Reviewed-by: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Jose Fonseca <jfonseca@vmware.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c9ef70346a1..351c0785aff 100644
--- a/meson.build
+++ b/meson.build
@@ -697,7 +697,7 @@ if with_platform_haiku
pre_args += '-DHAVE_HAIKU_PLATFORM'
endif
-prog_python = find_program('python3')
+prog_python = import('python3').find_python()
has_mako = run_command(
prog_python, '-c',
'''