summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2018-06-19 15:58:30 -0700
committerKeith Packard <keithp@keithp.com>2018-06-20 10:42:05 -0700
commit3f960c1338713d317ce6463be68cee162c968d8d (patch)
tree87c94a88d89cef1fb043d05aaaea2d853e824a37 /meson.build
parentf49d112a01f9bec79b0ddb028163dc189f663634 (diff)
vulkan: EXT_acquire_xlib_display requires libXrandr headers to build
When VK_USE_PLATFORM_XLIB_XRANDR_EXT is defined, vulkan.h includes X11/extensions/Xrandr.h for the RROutput typedef which is used in the vkGetRandROutputDisplayEXT interface. Make sure we have the required header by checking during the build, and also set CFLAGS to point at the right directory. We don't need to link against the library as we don't use any functions from there, so don't add the _LIBS value in the autotools build. Signed-off-by: Keith Packard <keithp@keithp.com> Fixes: dbac8e25f851ed44c51f "radv: Add EXT_acquire_xlib_display to radv driver [v2]" Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index e834adbb249..76aa10f81a5 100644
--- a/meson.build
+++ b/meson.build
@@ -1308,6 +1308,7 @@ dep_xcb_sync = null_dep
dep_xcb_xfixes = null_dep
dep_xshmfence = null_dep
dep_xcb_xrandr = null_dep
+dep_xlib_xrandr = null_dep
if with_platform_x11
if with_glx == 'xlib' or with_glx == 'gallium-xlib'
dep_x11 = dependency('x11')
@@ -1356,6 +1357,7 @@ if with_platform_x11
endif
if with_xlib_lease
dep_xcb_xrandr = dependency('xcb-randr', version : '>= 1.12')
+ dep_xlib_xrandr = dependency('xrandr', version : '>= 1.3')
endif
endif