summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMathieu Bridon <bochecha@daitauha.fr>2018-08-09 10:27:26 +0200
committerDylan Baker <dylan@pnwbakers.com>2018-08-10 15:15:09 -0700
commit2ee1c86d71bee5ddca2c8795b4d343e31d28df99 (patch)
tree434ff307fe52734f62ae83427accc863cb455778 /meson.build
parentbd27203f4d808763ac24ac94eb677cacf3e7cb99 (diff)
meson: Build with Python 3
Now that all the build scripts are compatible with both Python 2 and 3, we can flip the switch and tell Meson to use the latter. Since Meson already depends on Python 3 anyway, this means we don't need two different Python stacks to build Mesa. Signed-off-by: Mathieu Bridon <bochecha@daitauha.fr> Reviewed-by: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 334cf96ae70..7436164946b 100644
--- a/meson.build
+++ b/meson.build
@@ -697,10 +697,10 @@ if with_platform_haiku
pre_args += '-DHAVE_HAIKU_PLATFORM'
endif
-prog_python2 = find_program('python2')
-has_mako = run_command(prog_python2, '-c', 'import mako')
+prog_python = find_program('python3')
+has_mako = run_command(prog_python, '-c', 'import mako')
if has_mako.returncode() != 0
- error('Python (2.x) mako module required to build mesa.')
+ error('Python (3.x) mako module required to build mesa.')
endif
if cc.get_id() == 'gcc' and cc.version().version_compare('< 4.4.6')