summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorScott D Phillips <scott.d.phillips@intel.com>2018-05-04 17:11:13 -0700
committerJason Ekstrand <jason.ekstrand@intel.com>2018-05-31 16:51:35 -0700
commit943fecc5691b55b8ce8740d133dd70614effb72d (patch)
treeaa5bd576ca6fb71554e742460c69e90a86588a17 /configure.ac
parentf19ad5d31fde8c447119c5483b3e3972922e9991 (diff)
util: Add a randomized test for the virtual memory allocator
The test pseudo-randomly makes allocations and deallocations with the virtual memory allocator and checks that the results are consistent. Specifically, we test that: * no result from the allocator overlaps an already allocated range * allocated memory fulfills the stated alignment requirement * a failed result from the allocator could not have been fulfilled * memory freed to the allocator can later be allocated again v2: - fix if() in test() to actually run fill() v3: - add c++11 build flag (Jason) - test the full 64-bit range (Jason) Reviewed-by: Jason Ekstrand <jason@jlekstrand.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 62063c1c8a7..02dca4547c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3123,6 +3123,7 @@ AC_CONFIG_FILES([Makefile
src/util/Makefile
src/util/tests/hash_table/Makefile
src/util/tests/string_buffer/Makefile
+ src/util/tests/vma/Makefile
src/util/xmlpool/Makefile
src/vulkan/Makefile])