summaryrefslogtreecommitdiff
path: root/tests/modetest/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/modetest/Makefile.am')
-rw-r--r--tests/modetest/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/tests/modetest/Makefile.am b/tests/modetest/Makefile.am
index b5ec7717..065ae132 100644
--- a/tests/modetest/Makefile.am
+++ b/tests/modetest/Makefile.am
@@ -1,8 +1,7 @@
AM_CFLAGS = \
-I$(top_srcdir)/include/drm \
-I$(top_srcdir)/libkms/ \
- -I$(top_srcdir) \
- $(CAIRO_CFLAGS)
+ -I$(top_srcdir)
noinst_PROGRAMS = \
modetest
@@ -12,5 +11,9 @@ modetest_SOURCES = \
modetest_LDADD = \
$(top_builddir)/libdrm.la \
- $(top_builddir)/libkms/libkms.la \
- $(CAIRO_LIBS)
+ $(top_builddir)/libkms/libkms.la
+
+if HAVE_CAIRO
+AM_CFLAGS += $(CAIRO_CFLAGS)
+modetest_LDADD += $(CAIRO_LIBS)
+endif