summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2019-05-24 22:43:51 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2019-06-03 14:24:07 +0100
commit5aeacd5cc3fc37ff9e5dccb9e8ae63acdc12e521 (patch)
tree5e52b9a4200a7f09acf75cc2324c7159f0675782 /configure.ac
parent5a08524404ddd579857fea2bd977b770e9911032 (diff)
automake: Repair overlay build
This partially reverts commit 9141edea9931db0ca1dfcf476da8bdd370702cc4. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk> Cc: Petri Latvala <petri.latvala@intel.com> Cc: Daniel Vetter <daniel.vetter@intel.com> Reviewed-by: Tvrtko Ursulin <tvrtko.ursulin@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7467e620..90f38da1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -122,6 +122,20 @@ case "$target_cpu" in
;;
esac
+if test x"$build_x86" = xyes; then
+ PKG_CHECK_MODULES(OVERLAY_XVLIB, [xv x11 xext dri2proto >= 2.6], enable_overlay_xvlib=yes, enable_overlay_xvlib=no)
+ PKG_CHECK_MODULES(OVERLAY_XLIB, [cairo-xlib dri2proto >= 2.6], enable_overlay_xlib=yes, enable_overlay_xlib=no)
+
+ AC_CHECK_TOOL([LEG], [leg])
+ if test x"$LEG" != xleg; then
+ enable_overlay_xvlib="no"
+ enable_overlay_xlib="no"
+ AC_MSG_NOTICE([Failed to find leg, required for overlay, try : apt-get install peg])
+ fi
+else
+ enable_overlay_xvlib="no"
+ enable_overlay_xlib="no"
+fi
AM_CONDITIONAL(BUILD_X86, [test "x$build_x86" = xyes])
AM_CONDITIONAL(BUILD_OVERLAY_XVLIB, [test "x$enable_overlay_xvlib" = xyes])