summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cc6f3520f..95aa297da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1338,7 +1338,12 @@ AM_CONDITIONAL(DRI3, test "x$DRI3" = xyes)
if test "x$DRI" = xyes || test "x$DRI2" = xyes || test "x$DRI3" = xyes || test "x$CONFIG_UDEV_KMS" = xyes; then
if test "x$DRM" = xyes; then
AC_DEFINE(WITH_LIBDRM, 1, [Building with libdrm support])
- PKG_CHECK_MODULES([LIBDRM], $LIBDRM)
+ if test "x$DRI2" = xyes; then
+ dnl 2.4.65 is required for drmGetDevice
+ PKG_CHECK_MODULES([LIBDRM], libdrm >= 2.4.65)
+ else
+ PKG_CHECK_MODULES([LIBDRM], $LIBDRM)
+ fi
fi
fi