summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index faa0d6b..d680cf1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -78,6 +78,9 @@ file(GLOB_RECURSE PC_IN_FILES "*.pc.in")
foreach(pc_in_file ${PC_IN_FILES})
get_filename_component(pc_out_file ${pc_in_file} NAME)
string(REPLACE ".pc.in" ".pc" pc_out_file ${pc_out_file})
+ if (USE_QT5)
+ string(REPLACE "Qt" "Qt5" pc_out_file ${pc_out_file})
+ endif()
configure_file(${pc_in_file} ${CMAKE_CURRENT_BINARY_DIR}/${pc_out_file} @ONLY)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${pc_out_file}
DESTINATION ${QTGSTREAMER_PC_INSTALL_DIR})