summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGeorge Kiagiadakis <george.kiagiadakis@collabora.com>2012-04-07 18:50:20 +0300
committerGeorge Kiagiadakis <george.kiagiadakis@collabora.com>2012-04-07 18:50:20 +0300
commit7c6258481f04c57bd3c2b94e71eb7c3b50b8fc97 (patch)
tree9574a6bfa41f3221639a94b6f2c9ddc35675f8fe /CMakeLists.txt
parent40156ef6e43cea126bbf620fd145caba29104298 (diff)
cmake: Remove -Wcast-align from the compiler flags.
Unfortunately all the casts of Gst C object pointers to subclasses trigger this warning on architectures where it matters (ex. armel), so there is not much point in having the compilation output full of warnings that should be ignored.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 32ae046..066d5c2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -105,7 +105,7 @@ endif()
if (CMAKE_COMPILER_IS_GNUCXX)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -Wformat-security -Wundef -Wpointer-arith -Wcast-align -fno-common")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -Wformat-security -Wundef -Wpointer-arith -fno-common")
endif ()
set(LIB_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX} CACHE STRING "Destination directory for libraries")