summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTiago Vignatti <tiago.vignatti@nokia.com>2010-01-14 17:18:28 +0200
committerKeith Packard <keithp@keithp.com>2010-01-27 21:28:57 -0800
commit60b6477f6dc005a1b052be8c5e5a549550a4aa88 (patch)
treef8a3006a2eb094682e4cd1c2178f23e0b15acd58 /configure.ac
parentb4baab90c0d98bef98d485682d4a69a327a380d6 (diff)
dix/configure: remove null root cursor option
The default behavior of the server is to start with an invisible root cursor. Be such cursor invisible or inexistent (null), in the end it doesn't matter - for the user. The content on screen will be the same. Besides, there's no difference, in terms of performance, whether such cursor is invisible or simply null. The paths that both take inside the server are roughly the same. Therefore create a null root cursor becomes irrelevant. Signed-off-by: Tiago Vignatti <tiago.vignatti@nokia.com> Acked-by: Peter Hutterer <peter.hutterer@who-t.net> Acked-by: Daniel Stone <daniel@fooishbar.org> Signed-off-by: Keith Packard <keithp@keithp.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 0 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 425db40f6..ec9442bd3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -572,9 +572,6 @@ AC_ARG_ENABLE(install-libxf86config,
[Install libxf86config (default: disabled)]),
[INSTALL_LIBXF86CONFIG=$enableval],
[INSTALL_LIBXF86CONFIG=no])
-AC_ARG_ENABLE(null-root-cursor, AS_HELP_STRING([--enable-null-root-cursor], [Use an empty root cursor (default: use core cursor)]),
- [NULL_ROOT_CURSOR=$enableval],
- [NULL_ROOT_CURSOR=no])
AC_ARG_ENABLE(visibility, AC_HELP_STRING([--enable-visibility], [Enable symbol visibility (default: auto)]),
[SYMBOL_VISIBILITY=$enableval],
[SYMBOL_VISIBILITY=auto])
@@ -1187,10 +1184,6 @@ AC_CHECK_FUNC(strncasecmp, [], AC_DEFINE([NEED_STRNCASECMP], 1,
AC_CHECK_FUNC(strcasestr, [], AC_DEFINE([NEED_STRCASESTR], 1,
[Do not have 'strcasestr'.]))
-if test "x$NULL_ROOT_CURSOR" = xyes; then
- AC_DEFINE(NULL_ROOT_CURSOR, 1, [Use an empty root cursor])
-fi
-
PKG_CHECK_MODULES([XDMCP], [xdmcp], [have_libxdmcp="yes"], [have_libxdmcp="no"])
if test "x$have_libxdmcp" = xyes; then
AC_CHECK_LIB(Xdmcp, XdmcpWrap, [have_xdmcpwrap="yes"], [have_xdmcpwrap="no"], [$XDMCP_LIBS])