summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian König <deathsimple@vodafone.de>2011-07-14 13:57:23 +0200
committerChristian König <deathsimple@vodafone.de>2011-07-14 15:36:24 +0200
commit33bf410acedeaabe5c91e002e9194c383b4e1d9b (patch)
tree66f1f72b616795253163bbac1b29f82c35e6ee15 /configure.ac
parenta8ae8cf3f12e2cda4dd2eaaffab93fec2c23925a (diff)
g3dvl: check for existense of VDPAU header/libs
Building the VDPAU state tracker only works when the header/libs are available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4f473021853..75b9510f61e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1515,7 +1515,7 @@ if test "x$enable_gallium_g3dvl" = xyes; then
fi
if test "x$enable_vdpau" = xauto; then
- enable_vdpau=yes
+ PKG_CHECK_EXISTS([vdpau], [enable_vdpau=yes], [enable_vdpau=no])
fi
if test "x$enable_va" = xauto; then
@@ -1529,8 +1529,8 @@ if test "x$enable_xvmc" = xyes; then
HAVE_ST_XVMC="yes"
fi
-#TODO: Check for vdpau libs/headers
if test "x$enable_vdpau" = xyes; then
+ PKG_CHECK_MODULES([VDPAU], [vdpau >= 0.4.1])
GALLIUM_STATE_TRACKERS_DIRS="$GALLIUM_STATE_TRACKERS_DIRS vdpau"
HAVE_ST_VDPAU="yes"
fi