summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJose Fonseca <jfonseca@vmware.com>2015-03-03 16:58:21 +0000
committerJose Fonseca <jfonseca@vmware.com>2015-03-04 11:01:45 +0000
commit3acd7a34ab05b87521b74f626ec637e7fdcc6595 (patch)
treeec442924dfbd3e1f10786b28b3c2d9bc17c85ffe /configure.ac
parent5564c361b5cc1f5ec4be3622d7f9be601e3c268a (diff)
st/vega: Remove.
OpenVG API seems to have dwindled away. The code would still be interesting if we wanted to implement NV_path_rendering but given the trend of the next gen graphics APIs, it seems unlikely that this becomes ARB or core. v2: Remove a few "openvg" references left, per Emil Velikov. Reviewed-by: Emil Velikov <emil.l.velikov@gmail.com> v3: Update release notes.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 0 insertions, 31 deletions
diff --git a/configure.ac b/configure.ac
index c5abbfd078..ad64df0123 100644
--- a/configure.ac
+++ b/configure.ac
@@ -692,11 +692,6 @@ AC_ARG_ENABLE([gles2],
[enable support for OpenGL ES 2.x API @<:@default=disabled@:>@])],
[enable_gles2="$enableval"],
[enable_gles2=no])
-AC_ARG_ENABLE([openvg],
- [AS_HELP_STRING([--enable-openvg],
- [enable support for OpenVG API @<:@default=disabled@:>@])],
- [enable_openvg="$enableval"],
- [enable_openvg=no])
AC_ARG_ENABLE([dri],
[AS_HELP_STRING([--enable-dri],
@@ -827,7 +822,6 @@ if test "x$enable_opengl" = xno -a \
"x$enable_gles1" = xno -a \
"x$enable_gles2" = xno -a \
"x$enable_nine" = xno -a \
- "x$enable_openvg" = xno -a \
"x$enable_xa" = xno -a \
"x$enable_xvmc" = xno -a \
"x$enable_vdpau" = xno -a \
@@ -1548,29 +1542,6 @@ fi
AM_CONDITIONAL(HAVE_ST_XA, test "x$enable_xa" = xyes)
dnl
-dnl OpenVG configuration
-dnl
-VG_LIB_DEPS=""
-
-if test "x$enable_openvg" = xyes; then
- if test "x$enable_egl" = xno; then
- AC_MSG_ERROR([cannot enable OpenVG without EGL])
- fi
- if test -z "$with_gallium_drivers"; then
- AC_MSG_ERROR([cannot enable OpenVG without Gallium])
- fi
-
- AC_MSG_ERROR([Cannot enable OpenVG, because egl_gallium has been removed and
- OpenVG has not been integrated into standard libEGL yet])
-
- EGL_CLIENT_APIS="$EGL_CLIENT_APIS "'$(VG_LIB)'
- VG_LIB_DEPS="$VG_LIB_DEPS $SELINUX_LIBS $PTHREAD_LIBS"
- VG_PC_LIB_PRIV="-lm $CLOCK_LIB $PTHREAD_LIBS $DLOPEN_LIBS"
- AC_SUBST([VG_PC_LIB_PRIV])
-fi
-AM_CONDITIONAL(HAVE_OPENVG, test "x$enable_openvg" = xyes)
-
-dnl
dnl Gallium G3DVL configuration
dnl
if test -n "$with_gallium_drivers" -a "x$with_gallium_drivers" != xswrast; then
@@ -2400,7 +2371,6 @@ AC_CONFIG_FILES([Makefile
src/gallium/state_trackers/osmesa/Makefile
src/gallium/state_trackers/va/Makefile
src/gallium/state_trackers/vdpau/Makefile
- src/gallium/state_trackers/vega/Makefile
src/gallium/state_trackers/xa/Makefile
src/gallium/state_trackers/xvmc/Makefile
src/gallium/targets/d3dadapter9/Makefile
@@ -2478,7 +2448,6 @@ echo " includedir: $includedir"
dnl API info
echo ""
echo " OpenGL: $enable_opengl (ES1: $enable_gles1 ES2: $enable_gles2)"
-echo " OpenVG: $enable_openvg"
dnl Driver info
echo ""