summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Collingbourne <peter@pcc.me.uk>2014-11-17 22:16:15 +0000
committerPeter Collingbourne <peter@pcc.me.uk>2014-11-17 22:16:15 +0000
commit5b9a46b789b6077dcb8f2e2c39c0765d28924bfc (patch)
tree3f3b0ae796432fae2918aa7237311bcbe765d650 /CMakeLists.txt
parent2bd09db07fbda4350223d3ab6c14d2e0bc23ffef (diff)
CMake: Use the new USES_TERMINAL option for test suite targets when available.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@222181 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f2b3d32614..e3ddb26796 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,6 +16,12 @@ else()
endif()
endif()
+if(CMAKE_VERSION VERSION_LESS 3.1.20141117)
+ set(cmake_3_2_USES_TERMINAL)
+else()
+ set(cmake_3_2_USES_TERMINAL USES_TERMINAL)
+endif()
+
project(LLVM)
# Add path for custom modules