summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2015-03-23 20:04:00 +0000
committerChris Bieneman <beanz@apple.com>2015-03-23 20:04:00 +0000
commit07118a3546f0568ee8b07e506531bc6d1402178f (patch)
tree84469614c30ba0cd99317c36fe50000697b75936 /CMakeLists.txt
parent0c9684c947266b9f2df9d2e5b62ab0efb3bc4bf2 (diff)
Re-land: Generate targets for each lit suite.
Summary: This change makes CMake scan for lit suites and generate a target for each lit test suite. The targets follow the format check-<project>-<suite path>. For example: check-llvm-unit - Runs the LLVM unit tests check-llvm-codegen-arm - Runs the ARM codeine tests Note: These targets are not generated during multi-configuration generators (i.e. Xcode and Visual Studio) because target clutter impacts UI usability. * Also fixed a minor issue that Duncan pointed out to me I was passing the suite to lit twice Reviewers: chandlerc Subscribers: aemerson, llvm-commits Differential Revision: http://reviews.llvm.org/D8380 git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@233009 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bef66ec477..ea3fda39c3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -631,6 +631,11 @@ if( LLVM_INCLUDE_TESTS )
DEPENDS ${LLVM_LIT_DEPENDS}
ARGS ${LLVM_LIT_EXTRA_ARGS}
)
+
+ add_lit_testsuites(LLVM ${CMAKE_SOURCE_DIR}/test
+ PARAMS ${LLVM_LIT_PARAMS}
+ DEPENDS ${LLVM_LIT_DEPENDS}
+ ARGS ${LLVM_LIT_EXTRA_ARGS})
endif()
if (LLVM_INCLUDE_DOCS)