summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJulien Danjou <julien@danjou.info>2008-11-07 11:02:08 +0100
committerArnaud Fontaine <arnau@debian.org>2010-11-14 20:21:27 +0900
commite7651a13ab8dff941792c550294261c072f0b41c (patch)
tree421bc51bcb96b3119f7d6d33a385d50d093c8689 /configure.ac
parenta2ad3c92cbbd988031077124b26a3795f2ae253d (diff)
configure: stop if m4 is not found
Signed-off-by: Julien Danjou <julien@danjou.info>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 828ebea..e841559 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,7 +3,10 @@ AC_INIT([xcb-util],0.3.0,[xcb@lists.freedesktop.org])
AC_CONFIG_SRCDIR([Makefile.am])
AM_INIT_AUTOMAKE([foreign dist-bzip2])
-AC_CHECK_PROGS(M4, m4)
+AC_CHECK_PROGS(M4, m4, [no])
+if test $M4 = "no"; then
+ AC_MSG_ERROR([Can't find m4, please install it and try again])
+fi
AC_CHECK_PROGS(GPERF, gperf, [no])
if test $GPERF = "no"; then
AC_MSG_ERROR([Can't find gperf, please install it and try again])