summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJosh Triplett <josh@freedesktop.org>2006-02-18 16:49:41 -0800
committerJosh Triplett <josh@josh-mobile.localdomain>2006-02-18 16:49:41 -0800
commit85e1c50e9a2661945503e3362eaa481450a6fbd3 (patch)
tree5b09d347bebbf1f72ee234df40246174f04006b4 /configure.ac
Remove xcl and CVSROOT.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 33 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..4f5bbd7
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,33 @@
+AC_PREREQ(2.57)
+AC_INIT([xcb-util],0.1,[jamey@minilop.net])
+AC_CONFIG_SRCDIR([Makefile.am])
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
+
+AC_CHECK_PROGS(M4, m4)
+AC_CHECK_PROGS(GPERF, gperf, [no])
+if test $GPERF = "no"; then
+ AC_MSG_ERROR([Can't find gperf, please install it and try again])
+fi
+AC_PROG_CC
+AC_PROG_LIBTOOL
+
+xcbincludedir='${includedir}/X11/XCB'
+AC_SUBST(xcbincludedir)
+
+pkgconfigdir='${libdir}/pkgconfig'
+AC_SUBST(pkgconfigdir)
+
+PKG_CHECK_MODULES(XCB, xcb)
+
+AC_OUTPUT([Makefile
+ convenient/Makefile convenient/xcb-aux.pc
+ reply/Makefile reply/xcb-reply.pc
+ image/Makefile image/xcb-image.pc
+ atom/Makefile atom/xcb-atom.pc
+ event/Makefile event/xcb-event.pc
+ keysyms/Makefile keysyms/xcb-keysyms.pc
+ property/Makefile property/xcb-property.pc
+ icccm/Makefile icccm/xcb-icccm.pc
+ wm/Makefile wm/xcb-wm.pc
+ xcb_util_intro
+ ])