summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2011-03-06 17:52:44 -0500
committerArnaud Fontaine <arnau@debian.org>2011-03-07 04:06:06 +0100
commit9b9d682d42c17727bf2905a35cc93a017af9ee15 (patch)
tree5503fca67490fe996cce28e05a807e42f1e71af6 /Makefile.am
parent9d0425b633847b681f875fe35f50eea2a8f2e60f (diff)
config: generate ChangeLog and INSTALL
By copying a snippet of Makefile for xorg modules. One side-effect is that Makefile.in is no longer deleted on maintainer clean. This should never be done as it leaves your configuration in a half-broken state. Signed-off-by: Gaetan Nadon <memsize@videotron.ca> Signed-off-by: Arnaud Fontaine <arnau@debian.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 153a52b..5e49e1f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,15 @@
ACLOCAL_AMFLAGS = -I m4
-MAINTAINERCLEANFILES = Makefile.in
+MAINTAINERCLEANFILES = ChangeLog INSTALL
+
+.PHONY: ChangeLog INSTALL
+
+INSTALL:
+ $(INSTALL_CMD)
+
+ChangeLog:
+ $(CHANGELOG_CMD)
+
+dist-hook: ChangeLog INSTALL
SUBDIRS = renderutil