summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEamon Walsh <ewalsh@tycho.nsa.gov>2007-12-07 16:22:04 -0500
committerEamon Walsh <ewalsh@moss-charon.epoch.ncsc.mil>2007-12-07 16:22:04 -0500
commit7a74ba3d0212f9bfe021d6da9070f71cbc53f85b (patch)
treefa5f4c6552b1b1cb6380a5aa1ae63dfc5e397e0f /Makefile.am
parentbcd1dcec9b242d7e2185c1ae83d3884844a2647f (diff)
Generated the configure.ac and Makefile.am's in libxcb with the idea of
making each extension library individually selectable for build. Signed-off-by: Eamon Walsh <ewalsh@tycho.nsa.gov>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am167
1 files changed, 126 insertions, 41 deletions
diff --git a/Makefile.am b/Makefile.am
index 2dce719..440e9a8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,52 +4,137 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = \
xcb.pc \
-xcb-xlib.pc \
-xcb-composite.pc \
-xcb-damage.pc \
-xcb-dpms.pc \
-xcb-glx.pc \
-xcb-randr.pc \
-xcb-record.pc \
-xcb-render.pc \
-xcb-res.pc \
-xcb-screensaver.pc \
-xcb-shape.pc \
-xcb-shm.pc \
-xcb-sync.pc \
-xcb-xevie.pc \
-xcb-xf86dri.pc \
-xcb-xfixes.pc \
-xcb-xinerama.pc \
-xcb-xprint.pc \
-xcb-xtest.pc \
-xcb-xv.pc \
-xcb-xvmc.pc
+xcb-xlib.pc
+
+if BUILD_COMPOSITE
+pkgconfig_DATA += xcb-composite.pc
+endif
+if BUILD_DAMAGE
+pkgconfig_DATA += xcb-damage.pc
+endif
+if BUILD_DPMS
+pkgconfig_DATA += xcb-dpms.pc
+endif
+if BUILD_GLX
+pkgconfig_DATA += xcb-glx.pc
+endif
+if BUILD_RANDR
+pkgconfig_DATA += xcb-randr.pc
+endif
+if BUILD_RECORD
+pkgconfig_DATA += xcb-record.pc
+endif
+if BUILD_RENDER
+pkgconfig_DATA += xcb-render.pc
+endif
+if BUILD_RES
+pkgconfig_DATA += xcb-res.pc
+endif
+if BUILD_SCREENSAVER
+pkgconfig_DATA += xcb-screensaver.pc
+endif
+if BUILD_SHAPE
+pkgconfig_DATA += xcb-shape.pc
+endif
+if BUILD_SHM
+pkgconfig_DATA += xcb-shm.pc
+endif
+if BUILD_SYNC
+pkgconfig_DATA += xcb-sync.pc
+endif
+if BUILD_XEVIE
+pkgconfig_DATA += xcb-xevie.pc
+endif
+if BUILD_XF86DRI
+pkgconfig_DATA += xcb-xf86dri.pc
+endif
+if BUILD_XFIXES
+pkgconfig_DATA += xcb-xfixes.pc
+endif
+if BUILD_XINERAMA
+pkgconfig_DATA += xcb-xinerama.pc
+endif
+if BUILD_XPRINT
+pkgconfig_DATA += xcb-xprint.pc
+endif
+if BUILD_XTEST
+pkgconfig_DATA += xcb-xtest.pc
+endif
+if BUILD_XV
+pkgconfig_DATA += xcb-xv.pc
+endif
+if BUILD_XVMC
+pkgconfig_DATA += xcb-xvmc.pc
+endif
+
EXTRA_DIST = \
xcb.pc.in \
xcb-xlib.pc.in \
-xcb-composite.pc.in \
-xcb-damage.pc.in \
-xcb-dpms.pc.in \
-xcb-glx.pc.in \
-xcb-randr.pc.in \
-xcb-record.pc.in \
-xcb-render.pc.in \
-xcb-res.pc.in \
-xcb-screensaver.pc.in \
-xcb-shape.pc.in \
-xcb-shm.pc.in \
-xcb-sync.pc.in \
-xcb-xevie.pc.in \
-xcb-xinerama.pc.in \
-xcb-xf86dri.pc.in \
-xcb-xfixes.pc.in \
-xcb-xprint.pc.in \
-xcb-xtest.pc.in \
-xcb-xv.pc.in \
-xcb-xvmc.pc.in \
tools/README \
tools/api_conv.pl \
tools/constants \
autogen.sh
+
+if BUILD_COMPOSITE
+EXTRA_DIST += xcb-composite.pc.in
+endif
+if BUILD_DAMAGE
+EXTRA_DIST += xcb-damage.pc.in
+endif
+if BUILD_DPMS
+EXTRA_DIST += xcb-dpms.pc.in
+endif
+if BUILD_GLX
+EXTRA_DIST += xcb-glx.pc.in
+endif
+if BUILD_RANDR
+EXTRA_DIST += xcb-randr.pc.in
+endif
+if BUILD_RECORD
+EXTRA_DIST += xcb-record.pc.in
+endif
+if BUILD_RENDER
+EXTRA_DIST += xcb-render.pc.in
+endif
+if BUILD_RES
+EXTRA_DIST += xcb-res.pc.in
+endif
+if BUILD_SCREENSAVER
+EXTRA_DIST += xcb-screensaver.pc.in
+endif
+if BUILD_SHAPE
+EXTRA_DIST += xcb-shape.pc.in
+endif
+if BUILD_SHM
+EXTRA_DIST += xcb-shm.pc.in
+endif
+if BUILD_SYNC
+EXTRA_DIST += xcb-sync.pc.in
+endif
+if BUILD_XEVIE
+EXTRA_DIST += xcb-xevie.pc.in
+endif
+if BUILD_XF86DRI
+EXTRA_DIST += xcb-xf86dri.pc.in
+endif
+if BUILD_XFIXES
+EXTRA_DIST += xcb-xfixes.pc.in
+endif
+if BUILD_XINERAMA
+EXTRA_DIST += xcb-xinerama.pc.in
+endif
+if BUILD_XPRINT
+EXTRA_DIST += xcb-xprint.pc.in
+endif
+if BUILD_XTEST
+EXTRA_DIST += xcb-xtest.pc.in
+endif
+if BUILD_XV
+EXTRA_DIST += xcb-xv.pc.in
+endif
+if BUILD_XVMC
+EXTRA_DIST += xcb-xvmc.pc.in
+endif
+
+