summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorsewardj <sewardj@a5019735-40e9-0310-863c-91ae7b9d1cf9>2011-04-13 14:57:44 +0000
committersewardj <sewardj@a5019735-40e9-0310-863c-91ae7b9d1cf9>2011-04-13 14:57:44 +0000
commitd50650d6cb0e3577ba28b470a4e5f5df8368afaa (patch)
treef6c409a292a1eb84c22cd70c50ebb789564d70f3 /configure.in
parentde2b6fca539c98f0f2509be414060ab362e02ed6 (diff)
s390x: rewrite some testcases. To make my testing and debugging life
simpler, I've rewritten those testcases from none/tests/s390x that require binutils to recognize opcodes defined in the extended-immediate and general-instruction-extension facilities. As a side effect this change removes the special casing in none/tests/s390x/Makefile.am and the configury bits to support it. Fixes #270115. (Florian Krohm, britzel@acm.org) git-svn-id: svn://svn.valgrind.org/valgrind/trunk@11693 a5019735-40e9-0310-863c-91ae7b9d1cf9
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in44
1 files changed, 0 insertions, 44 deletions
diff --git a/configure.in b/configure.in
index 806d33ee..a465660f 100644
--- a/configure.in
+++ b/configure.in
@@ -1397,52 +1397,8 @@ if test x$ac_have_as_ppc_mftocrf = xyes ; then
fi
-# what facilities does the s390 assembler support?
-AC_MSG_CHECKING([if s390 as supports extended immediate])
-CFLAGS=-march=z9-109
-AC_TRY_COMPILE(, [
-__asm__ __volatile__("flogr 1,2");
-],
-[
-ac_have_as_s390_ei=yes
-AC_MSG_RESULT([yes])
-], [
-ac_have_as_s390_ei=no
-AC_MSG_RESULT([no])
-])
-AM_CONDITIONAL(S390_BUILDS_EI, test x$ac_have_as_s390_ei = xyes)
-
-AC_MSG_CHECKING([if s390 as supports general instruction extension])
-CFLAGS=-march=z10
-AC_TRY_COMPILE(, [
-__asm__ __volatile__("chsi 1,0");
-],
-[
-ac_have_as_s390_ge=yes
-AC_MSG_RESULT([yes])
-], [
-ac_have_as_s390_ge=no
-AC_MSG_RESULT([no])
-])
-AM_CONDITIONAL(S390_BUILDS_GE, test x$ac_have_as_s390_ge = xyes)
-CFLAGS=$safe_CFLAGS
-
-AC_MSG_CHECKING([if s390 as supports z196 instructions])
-CFLAGS=-march=z196
-AC_TRY_COMPILE(, [
-__asm__ __volatile__("locr 1,2,1");
-],
-[
-ac_have_as_s390_z196=yes
-AC_MSG_RESULT([yes])
-], [
-ac_have_as_s390_z196=no
-AC_MSG_RESULT([no])
-])
-AM_CONDITIONAL(S390_BUILDS_Z196, test x$ac_have_as_s390_z196 = xyes)
CFLAGS=$safe_CFLAGS
-
# does the x86/amd64 assembler understand SSE3 instructions?
# Note, this doesn't generate a C-level symbol. It generates a
# automake-level symbol (BUILD_SSE3_TESTS), used in test Makefile.am's