summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornjn <njn@a5019735-40e9-0310-863c-91ae7b9d1cf9>2010-07-05 07:21:22 +0000
committernjn <njn@a5019735-40e9-0310-863c-91ae7b9d1cf9>2010-07-05 07:21:22 +0000
commitcc58ceae5f6e6a28f45c0dd0f372a60408873981 (patch)
treeab75708b7afe2d4d3fe8a76f3a566359c6e6344b /configure.in
parent320705fdb4ee91a69030d2024eec6e9a613c86c4 (diff)
Convert x86-darwin to amd64-darwin at configure time, because Macs report as
32-bit even though almost all of them support 64-bit as well. A hack, but one that will make just about everyone's lives easier. git-svn-id: svn://svn.valgrind.org/valgrind/trunk@11208 a5019735-40e9-0310-863c-91ae7b9d1cf9
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 8 insertions, 13 deletions
diff --git a/configure.in b/configure.in
index 073910af..62e18373 100644
--- a/configure.in
+++ b/configure.in
@@ -291,7 +291,7 @@ case "${host_os}" in
*)
AC_MSG_RESULT([no (${host_os})])
- AC_MSG_ERROR([Valgrind is operating system specific. Sorry. Please consider doing a port.])
+ AC_MSG_ERROR([Valgrind is operating system specific. Sorry.])
;;
esac
@@ -473,18 +473,13 @@ case "$ARCH_MAX-$VGCONF_OS" in
fi
AC_MSG_RESULT([ok (${ARCH_MAX}-${VGCONF_OS})])
;;
- x86-darwin)
- VGCONF_ARCH_PRI="x86"
- VGCONF_ARCH_SEC=""
- VGCONF_PLATFORM_PRI_CAPS="X86_DARWIN"
- VGCONF_PLATFORM_SEC_CAPS=""
- valt_load_address_pri_norml="0x38000000"
- valt_load_address_pri_inner="0x28000000"
- valt_load_address_sec_norml="0xUNSET"
- valt_load_address_sec_inner="0xUNSET"
- AC_MSG_RESULT([ok (${ARCH_MAX}-${VGCONF_OS})])
- ;;
- amd64-darwin)
+ # Darwin gets identified as 32-bit even when it supports 64-bit.
+ # (Not sure why, possibly because 'uname' returns "i386"?) Just about
+ # all Macs support both 32-bit and 64-bit, so we just build both. If
+ # someone has a really old 32-bit only machine they can (hopefully?)
+ # build with --enable-only32bit. See bug 243362.
+ x86-darwin|amd64-darwin)
+ ARCH_MAX="amd64"
valt_load_address_sec_norml="0xUNSET"
valt_load_address_sec_inner="0xUNSET"
if test x$vg_cv_only64bit = xyes; then