summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorsewardj <sewardj@a5019735-40e9-0310-863c-91ae7b9d1cf9>2011-04-05 13:20:53 +0000
committersewardj <sewardj@a5019735-40e9-0310-863c-91ae7b9d1cf9>2011-04-05 13:20:53 +0000
commitaba3533d4cf547c3950144a00dca9258631a32bd (patch)
treed8bcf31f1ea835f3069a348529718fda81f5aad1 /configure.in
parent669b910a82c120019727f87045c721992c8d0c0f (diff)
Testcases for s390x conditional load and store. See #269209.
(Christian Borntraeger, borntraeger@de.ibm.com) git-svn-id: svn://svn.valgrind.org/valgrind/trunk@11685 a5019735-40e9-0310-863c-91ae7b9d1cf9
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b126204b..806d33ee 100644
--- a/configure.in
+++ b/configure.in
@@ -1427,6 +1427,22 @@ AC_MSG_RESULT([no])
AM_CONDITIONAL(S390_BUILDS_GE, test x$ac_have_as_s390_ge = xyes)
CFLAGS=$safe_CFLAGS
+AC_MSG_CHECKING([if s390 as supports z196 instructions])
+CFLAGS=-march=z196
+AC_TRY_COMPILE(, [
+__asm__ __volatile__("locr 1,2,1");
+],
+[
+ac_have_as_s390_z196=yes
+AC_MSG_RESULT([yes])
+], [
+ac_have_as_s390_z196=no
+AC_MSG_RESULT([no])
+])
+AM_CONDITIONAL(S390_BUILDS_Z196, test x$ac_have_as_s390_z196 = xyes)
+CFLAGS=$safe_CFLAGS
+
+
# does the x86/amd64 assembler understand SSE3 instructions?
# Note, this doesn't generate a C-level symbol. It generates a
# automake-level symbol (BUILD_SSE3_TESTS), used in test Makefile.am's