summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarc Dietrich <marvin24@gmx.de>2017-11-29 22:25:05 +0100
committerDylan Baker <dylan@pnwbakers.com>2017-12-01 17:09:42 -0800
commitd93fabb013279d06ab025448afce1e5f665880ee (patch)
tree82e9f16e6e496585f7811fecf1bb92cf3af5788c /meson.build
parent0ed952c7e9b811bc11dec64bd4bebcdf4222cc85 (diff)
configure: avoid testing for negative compiler options
gcc seems to always accept unsupported negative compiler warning options: echo "int i;" | gcc -c -xc -Wno-bob - # no error echo "int i;" | gcc -c -xc -Walice - # unsupported compiler option Inverting the options fixes the tests. V2: fix options in meson build Reviewed-by: Matt Turner <mattst88@gmail.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com> Signed-off-by: Marc Dietrich <marvin24@gmx.de>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build23
1 files changed, 15 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 65c6b98609..f227bc3e01 100644
--- a/meson.build
+++ b/meson.build
@@ -503,11 +503,25 @@ endif
cpp = meson.get_compiler('cpp')
cpp_args = []
foreach a : ['-Wall', '-fno-math-errno', '-fno-trapping-math',
- '-Qunused-arguments', '-Wno-non-virtual-dtor']
+ '-Qunused-arguments']
if cpp.has_argument(a)
cpp_args += a
endif
endforeach
+
+# For some reason, the test for -Wno-foo always succeeds with gcc, even if the
+# option is not supported. Hence, check for -Wfoo instead.
+if cpp.has_argument('-Wnon-virtual-dtor')
+ cpp_args += '-Wno-non-virtual-dtor'
+endif
+
+no_override_init_args = []
+foreach a : ['override-init', 'initializer-overrides']
+ if cc.has_argument('-W' + a)
+ no_override_init_args += '-Wno-' + a
+ endif
+endforeach
+
cpp_vis_args = []
if cpp.has_argument('-fvisibility=hidden')
cpp_vis_args += '-fvisibility=hidden'
@@ -527,13 +541,6 @@ foreach a : ['-Werror=pointer-arith', '-Werror=vla']
endif
endforeach
-no_override_init_args = []
-foreach a : ['-Wno-override-init', '-Wno-initializer-overrides']
- if cc.has_argument(a)
- no_override_init_args += a
- endif
-endforeach
-
if host_machine.cpu_family().startswith('x86')
pre_args += '-DHAVE_SSE41'
with_sse41 = true