summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarc Dietrich <marvin24@gmx.de>2018-01-23 15:49:43 +0100
committerEric Engestrom <eric.engestrom@imgtec.com>2018-01-23 15:39:57 +0000
commit911ca587f8785a90702f88d3c9044b7149e6d2b3 (patch)
tree8dd99437be05c1cece31a2c4c0a0bf400335531f /meson.build
parent5a4dc285002e1924dbc8c72d17481a3dbc4c0142 (diff)
meson: fix some defines misspelled errors in meson.build
Defines - HAVE_FUNC_ATTRIBUTE_RETURNS_NONNULL - HAVE_FUNC_ATTRIBUTE_VISIBILITY were misspelled. Signed-off-by: Marc Dietrich <marvin24@gmx.de> Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index f3179c3806..97619f786b 100644
--- a/meson.build
+++ b/meson.build
@@ -692,14 +692,14 @@ if cc.compiles('struct __attribute__((packed)) foo { int bar; };',
endif
if cc.compiles('int *foo(void) __attribute__((returns_nonnull));',
name : '__attribute__((returns_nonnull))')
- pre_args += '-DHAVE_FUNC_ATTRIBUTE_NONNULL'
+ pre_args += '-DHAVE_FUNC_ATTRIBUTE_RETURNS_NONNULL'
endif
if cc.compiles('''int foo_def(void) __attribute__((visibility("default")));
int foo_hid(void) __attribute__((visibility("hidden")));
int foo_int(void) __attribute__((visibility("internal")));
int foo_pro(void) __attribute__((visibility("protected")));''',
name : '__attribute__((visibility(...)))')
- pre_args += '-DHAVE_FUNC_ATTRIBUTE_VISBILITY'
+ pre_args += '-DHAVE_FUNC_ATTRIBUTE_VISIBILITY'
endif
if cc.compiles('int foo(void) { return 0; } int bar(void) __attribute__((alias("foo")));',
name : '__attribute__((alias(...)))')