summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@imgtec.com>2017-12-07 16:03:04 +0000
committerEric Engestrom <eric.engestrom@imgtec.com>2018-01-31 11:17:03 +0000
commit86168ed31c52ca5be3b618a5aae2e5d8990f4c31 (patch)
tree56e8ca0da06bcbdc19e9c59b429225c7f7201561 /meson.build
parent724916c8a84b5bba8f880f17da936585d52c97b6 (diff)
meson: dedup gallium-omx logic
Signed-off-by: Eric Engestrom <eric.engestrom@imgtec.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build38
1 files changed, 19 insertions, 19 deletions
diff --git a/meson.build b/meson.build
index 67702bded2..94c9bdc2bb 100644
--- a/meson.build
+++ b/meson.build
@@ -445,32 +445,32 @@ if xvmc_drivers_path == ''
xvmc_drivers_path = get_option('libdir')
endif
-dep_omx = []
_omx = get_option('gallium-omx')
-if _omx == 'auto'
- if not system_has_kms_drm
- with_gallium_omx = false
- elif not with_platform_x11
- with_gallium_omx = false
- elif not (with_gallium_r600 or with_gallium_radeonsi or with_gallium_nouveau)
- with_gallium_omx = false
+if not system_has_kms_drm
+ if _omx == 'true'
+ error('OMX state tracker can only be built on unix-like OSes.')
else
- dep_omx = dependency('libomxil-bellagio', required : false)
- with_gallium_omx = dep_omx.found()
+ _omx = 'false'
endif
-elif _omx == 'true'
- if not system_has_kms_drm
- error('OMX state tracker can only be built on DRM/KMS OSes.')
- elif not (with_platform_x11 or with_platform_drm)
+elif not (with_platform_x11 or with_platform_drm)
+ if _omx == 'true'
error('OMX state tracker requires X11 or drm platform support.')
- with_gallium_omx = false
- elif not (with_gallium_r600 or with_gallium_radeonsi or with_gallium_nouveau)
+ else
+ _omx = 'false'
+ endif
+elif not (with_gallium_r600 or with_gallium_radeonsi or with_gallium_nouveau)
+ if _omx == 'true'
error('OMX state tracker requires at least one of the following gallium drivers: r600, radeonsi, nouveau.')
+ else
+ _omx = 'false'
endif
+elif _omx == 'auto'
+ _omx = 'true'
+endif
+with_gallium_omx = _omx == 'true'
+dep_omx = []
+if with_gallium_omx
dep_omx = dependency('libomxil-bellagio')
- with_gallium_omx = true
-else
- with_gallium_omx = false
endif
omx_drivers_path = get_option('omx-libs-path')