summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJason Ekstrand <jason.ekstrand@intel.com>2017-08-16 17:16:45 -0700
committerJason Ekstrand <jason.ekstrand@intel.com>2017-12-04 09:21:09 -0800
commit0c49aa0624c289164b5501a8724b6d9fdbae7f49 (patch)
tree55af9d527c5cd4820db9a415d2be7003be4adf49 /meson.build
parent591a07632c913cadb1802196c0a50480b354d73c (diff)
util: Add a NORETURN macro
Reviewed-by: Tapani Pälli <tapani.palli@intel.com> Reviewed-by: Ian Romanick <idr@freedesktop.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f227bc3e01..ddc4a44eb6 100644
--- a/meson.build
+++ b/meson.build
@@ -479,6 +479,10 @@ if cc.compiles('int foo(void) { return 0; } int bar(void) __attribute__((alias("
name : '__attribute__((alias(...)))')
pre_args += '-DHAVE_FUNC_ATTRIBUTE_ALIAS'
endif
+if cc.compiles('int foo(void) __attribute__((__noreturn__));',
+ name : '__attribute__((__noreturn__))')
+ pre_args += '-DHAVE_FUNC_ATTRIBUTE_NORETURN'
+endif
# TODO: this is very incomplete
if ['linux', 'cygwin'].contains(host_machine.system())