summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..54d4901
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,18 @@
+configure_lit_site_cfg(
+ ${CMAKE_CURRENT_SOURCE_DIR}/lit.site.cfg.py.in
+ ${CMAKE_CURRENT_BINARY_DIR}/lit.site.cfg.py
+ MAIN_CONFIG
+ ${CMAKE_CURRENT_SOURCE_DIR}/lit.cfg.py
+ )
+
+list(APPEND LLVM_SPIRV_TEST_DEPS
+ FileCheck count not
+ llvm-as
+ llvm-dis
+ llvm-spirv
+)
+
+add_lit_testsuite(check-llvm-spirv "Running the LLVM-SPIRV regression tests"
+ ${CMAKE_CURRENT_BINARY_DIR}
+ DEPENDS ${LLVM_SPIRV_TEST_DEPS}
+ )