summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2011-04-23 13:04:11 -0400
committerKristian Høgsberg <krh@bitplanet.net>2011-04-23 13:04:11 -0400
commit02ec0a5d3a42ff7ceff54acdcd57fad8c5573912 (patch)
tree4aeee7c556a76a72fcd6562d425de237a7533184 /configure.ac
parentcce1aecd3cd9db0454064eb0d7edfafae9b65421 (diff)
compositor: Support loadable shells
The shell module is responsible for implementing the higher level compositor behavior. We default to the desktop-lite shell built in to the compositor.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 960f134..8873bd0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,8 +15,16 @@ AM_SILENT_RULES([yes])
AC_PROG_CC
AC_PROG_RANLIB
+# Initialize libtool
+LT_PREREQ([2.2])
+LT_INIT
+
PKG_PROG_PKG_CONFIG()
+AC_CHECK_FUNC([dlopen], [],
+ AC_CHECK_LIB([dl], [dlopen], DLOPEN_LIBS="-ldl"))
+AC_SUBST(DLOPEN_LIBS)
+
PKG_CHECK_MODULES(COMPOSITOR,
[wayland-server wayland-client wayland-egl egl >= 7.10 glesv2 gdk-pixbuf-2.0 libudev >= 136 libdrm >= 2.4.23] pixman-1 x11 x11-xcb)
PKG_CHECK_MODULES(SIMPLE_CLIENT, [egl >= 7.10 glesv2 wayland-client wayland-egl])