summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGwenole Beauchesne <gwenole.beauchesne@intel.com>2011-07-26 19:48:25 +0800
committerXiang, Haihao <haihao.xiang@intel.com>2011-07-27 14:18:39 +0800
commitf48a802937cbd74e40dc503f712439433b77da71 (patch)
tree8fa79c4dbd36b92d9f31a45365d953930fff8569 /Makefile.am
parent74f1ed222179614233efb316374b0603df46b6d8 (diff)
i965_drv_video: don't export internal driver functions.
Make sure to use our internal functions. In particular, we override some DRM functions and they have to be used. e.g. this fixes VA/GLX.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c106aae..405489b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,7 +23,6 @@
SUBDIRS = shaders
INCLUDES = \
- -Wall \
-I$(top_srcdir) \
-I$(top_srcdir)/va \
-I$(top_srcdir)/va/x11 \
@@ -31,6 +30,11 @@ INCLUDES = \
$(DRM_CFLAGS) \
$(NULL)
+driver_cflags = \
+ -Wall \
+ -fvisibility=hidden \
+ $(NULL)
+
driver_ldflags = \
-module -avoid-version \
-no-undefined \
@@ -88,6 +92,7 @@ source_h = \
i965_drv_video_la_LTLIBRARIES = i965_drv_video.la
i965_drv_video_ladir = $(LIBVA_DRIVERS_PATH)
+i965_drv_video_la_CFLAGS = $(driver_cflags)
i965_drv_video_la_LDFLAGS = $(driver_ldflags)
i965_drv_video_la_LIBADD = $(top_builddir)/va/libva-x11.la -lpthread
i965_drv_video_la_SOURCES = $(source_c)