summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b37d62d..535aac9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,6 +43,10 @@ AC_DEFUN([GWM_OPTIONAL_PACKAGE],[
])
AC_DEFINE(_GNU_SOURCE, 1, [Enable GNU extensions on systems that have them.])
+AH_BOTTOM([/* If we haven't been told that we're debugging, assume we aren't. */
+#ifndef DEBUG
+#define NDEBUG 1
+#endif])
# Checks for programs:
AC_PROG_CC
@@ -77,6 +81,9 @@ AC_SEARCH_LIBS(iconv, iconv)
# Checks for header files:
AC_CHECK_HEADERS(iconv.h mcheck.h poll.h)
+# Checks for types:
+AC_TYPE_UINT64_T
+
# Checks for functions:
AC_CHECK_FUNCS(iconv mtrace ppoll)