summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNicolas Bruguier <nicolas.bruguier@supersonicimagine.fr>2009-05-26 14:10:05 +0200
committerNicolas Bruguier <nicolas.bruguier@supersonicimagine.fr>2009-05-26 14:10:05 +0200
commitd1bb9bd0087f2236c4dbb298b2ba7e4f5c5cb244 (patch)
tree1b1f8d595365caddf29ce20b60fdd385032d14d7 /configure.ac
parent7cfaac7434728b225ef623c46bd49e361b926ff7 (diff)
Add properties save and restore with hal callout
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 18 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index dd3f462..ef22b55 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,11 +61,8 @@ AC_ARG_WITH(config-dir,
EVTOUCH2_CONFIG_FILE=$configdir/evtouch2.conf
AC_SUBST(EVTOUCH2_CONFIG_FILE)
-# Checks for extensions
XORG_DRIVER_CHECK_EXT(XINPUT, inputproto)
-# Checks for pkg-config packages. We need to be able to override sdkdir
-# to satisfy silly distcheck requirements.
PKG_CHECK_MODULES(XORG, xorg-server xproto $REQUIRED_MODULES)
XORG_CFLAGS="$CWARNFLAGS $XORG_CFLAGS"
AC_ARG_WITH([sdkdir], [],
@@ -73,9 +70,24 @@ AC_ARG_WITH([sdkdir], [],
[sdkdir=`$PKG_CONFIG --variable=sdkdir xorg-server`])
AC_SUBST([sdkdir])
-# Checks for libraries.
+PKG_CHECK_MODULES(EVTOUCH2_HAL_TOOLS, [hal])
+AC_SUBST(EVTOUCH2_HAL_TOOLS_CFLAGS)
+AC_SUBST(EVTOUCH2_HAL_TOOLS_LIBS)
+
+hal_callouts_dir="`$PKG_CONFIG --variable libdir hal`/hal"
+AC_ARG_WITH(hal_callouts_dir, AC_HELP_STRING([--with-hal-callouts-dir=DIR],
+ [Directory where HAL expects its callout to be located]),,
+ with_hal_callouts_dir="$hal_callouts_dir")
+HALCALLOUTSDIR="$with_hal_callouts_dir"
+AC_SUBST(HALCALLOUTSDIR)
+
+hal_fdi_dir="`$PKG_CONFIG --variable prefix hal`/share/hal/fdi"
+AC_ARG_WITH(hal_fdi_dir, AC_HELP_STRING([--with-hal-fdi-dir=DIR],
+ [Directory where HAL expects its fdi files to be located]),,
+ with_hal_fdi_dir="$hal_fdi_dir")
+HALFDIDIR="$with_hal_fdi_dir"
+AC_SUBST(HALFDIDIR)
-# Checks for header files.
AC_HEADER_STDC
DRIVER_NAME=evtouch2
@@ -87,6 +99,7 @@ XORG_CHANGELOG
AC_OUTPUT([Makefile
src/Makefile
+ tools/Makefile
man/Makefile
include/Makefile
xorg-evtouch2.pc])