summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Fonseca <jfonseca@vmware.com>2014-04-29 14:29:33 +0100
committerJosé Fonseca <jfonseca@vmware.com>2014-04-30 10:41:54 +0100
commit34f2a5d35ec7637e3ad9fcdf35959ce45f3cd254 (patch)
tree775b21bccc35b8599ab6615eca5ce640477a9b9e /CMakeLists.txt
parent82ae62acca79fa888284cf19ff7231cae0ace51f (diff)
cmake: Fix -Wdeclaration-after-statement detection.
Copy'n'paste typo. Trivial. Reviewed-by: Brian Paul <brianp@vmware.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cbdccf165..3b051f725 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -220,7 +220,7 @@ if (NOT MSVC)
# Unfortunately MSVC does not support C99. Among all features enabled
# by C99, declarations after statements is the most frequently used.
# For portability sake, we request gcc to warn when this is used.
- CHECK_C_COMPILER_FLAG("-Wall" C_COMPILER_FLAG_WDECL_AFTER_STMT)
+ CHECK_C_COMPILER_FLAG("-Wdeclaration-after-statement" C_COMPILER_FLAG_WDECL_AFTER_STMT)
IF (C_COMPILER_FLAG_WDECL_AFTER_STMT)
SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wdeclaration-after-statement")
ENDIF (C_COMPILER_FLAG_WDECL_AFTER_STMT)