summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2020-04-07 19:32:15 +0100
committerFrediano Ziglio <fziglio@redhat.com>2020-04-08 07:10:30 +0100
commit26bbb85c150f882c05399e4c574208b8b1242082 (patch)
treeee6e47f3bb0829232c8cd2e562113cf4b10897f6 /meson.build
parent595132dca812e408b7841786f947d28321d577f2 (diff)
build: Fix librt and libm dependencies in Meson
They need to be requested without the lib prefix, otherwise a generated pkg-config file ends up with absolute paths instead of -l flags. Signed-off-by: James Le Cuirot <chewi@gentoo.org> Acked-by: Frediano Ziglio <fziglio@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 1685c077..f9090a82 100644
--- a/meson.build
+++ b/meson.build
@@ -102,7 +102,7 @@ foreach dep : ['libjpeg', 'zlib']
endforeach
if host_machine.system() != 'windows'
- foreach dep : ['librt', 'libm']
+ foreach dep : ['rt', 'm']
spice_server_deps += compiler.find_library(dep)
endforeach
else