summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFrediano Ziglio <fziglio@redhat.com>2017-02-28 11:11:56 +0000
committerFrediano Ziglio <fziglio@redhat.com>2017-08-25 09:37:17 +0100
commit8cdea23d1d46a9a51fdbd655f45a62185a2e8427 (patch)
tree068df8502488cdbff9db58f482dad5807f68ad02 /configure.ac
parent3a5007d18fc8eaba666dd5874a613b3a0b680cc2 (diff)
display-channel: Check that all structure are destroyed during finalize
The leak detector we use currently is not enough to detect some kind of leak in DisplayChannel so manually test. These tests are enabled only when --enable-extra-checks is passed to configure. Signed-off-by: Frediano Ziglio <fziglio@redhat.com> Acked-by: Jonathon Jongsma <jjongsma@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e1e74862..a840eebd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -247,6 +247,9 @@ AC_ARG_ENABLE([extra-checks],
AS_HELP_STRING([--enable-extra-checks=@<:@yes/no@:>@],
[Enable expensive checks @<:@default=no@:>@]))
AM_CONDITIONAL(ENABLE_EXTRA_CHECKS, test "$enable_extra_checks" = "yes")
+AC_DEFINE_UNQUOTED([ENABLE_EXTRA_CHECKS],
+ [$(test "x$enable_extra_checks" = xyes && echo 1 || echo 0)],
+ [Define to 1 to enable extra checks on code otherwise define to 0])
dnl ===========================================================================
dnl check compiler flags