summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2018-06-05 11:26:58 +0200
committerFrediano Ziglio <fziglio@redhat.com>2018-06-05 14:10:02 +0100
commitf5224738425a7e97e1c32ea85bb3b243e50d4e22 (patch)
tree940d210e4ff97d90fc611aae5ade3ef43e2d3d86 /meson.build
parent72b0d603e128cd3af15974fe6b3e4b56ea9c6f34 (diff)
build: By default, error out if Opus is missing
Following the commit disabling celt by default, it's quite easy to have a build without both celt and opus. After this commit, Opus will have to be installed for a successful build unless one passes --disable-opus. Signed-off-by: Christophe Fergeau <cfergeau@redhat.com> Acked-by: Frediano Ziglio <fziglio@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 6 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 4dd4610..2cf2c3c 100644
--- a/meson.build
+++ b/meson.build
@@ -118,12 +118,13 @@ endforeach
#
# Non-mandatory/optional dependencies
#
-deps = [['opus', '>= 0.9.14', 'HAVE_OPUS'],]
-
# Check deps which are optional but enabled by default. This foreach block only
# checks the option, and adds the package to the deps list, while the real check
# for the dependency is done in the foeach block below.
-optional_deps = [['celt051', '>= 0.5.1.1', 'HAVE_CELT051'],]
+optional_deps = [
+ ['celt051', '>= 0.5.1.1', false, 'HAVE_CELT051'],
+ ['opus', '>= 0.9.14', true, 'HAVE_OPUS'],
+ ]
foreach dep : optional_deps
if get_option(dep[0])
deps += [dep]
@@ -131,10 +132,10 @@ foreach dep : optional_deps
endforeach
foreach dep : deps
- d = dependency(dep[0], required : false, version : dep[1])
+ d = dependency(dep[0], required : dep[2], version : dep[1])
if d.found()
spice_common_deps += d
- spice_common_config_data.set(dep[2], '1')
+ spice_common_config_data.set(dep[3], '1')
endif
endforeach