summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEduardo Lima (Etrunko) <etrunko@redhat.com>2019-02-01 14:40:01 -0200
committerEduardo Lima (Etrunko) <etrunko@redhat.com>2019-02-13 14:42:04 -0200
commit02530a80dfa45c936215c47b8e3aa56720eb46b8 (patch)
treecbd50ed45758fa026172d3a3c88c8664c631b570 /meson.build
parent811fff0791391185c06b5831c6a736b0409b90b8 (diff)
meson: Bump requirement to 0.48
This version is already required by spice-gtk and is soon to be required by spice-server as well, so there is no much sense in keeping it for spice-common. It is necessary to update the usage of the python module as described in the documentation: https://mesonbuild.com/Release-notes-for-0-48-0.html#python3-module-is-deprecated Which gets rid of the following warning message: WARNING: Deprecated features used: * 0.48.0: {'python3 module'} Signed-off-by: Eduardo Lima (Etrunko) <etrunko@redhat.com> Acked-by: Frediano Ziglio <fziglio@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 9474618..f451f1c 100644
--- a/meson.build
+++ b/meson.build
@@ -2,7 +2,7 @@
# project definition
#
project('spice-common', 'c',
- meson_version : '>= 0.47.0',
+ meson_version : '>= 0.48.0',
license : 'LGPLv2.1')
if not meson.is_subproject()
@@ -133,8 +133,8 @@ foreach dep, version : optional_deps
endforeach
# Python
-py_module = import('python3')
-python = py_module.find_python()
+py_module = import('python')
+python = py_module.find_installation()
if get_option('python-checks')
foreach module : ['six', 'pyparsing']