summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorFabrice Fontaine <fontaine.fabrice@gmail.com>2019-11-15 11:36:14 +0100
committerFrediano Ziglio <fziglio@redhat.com>2019-11-18 11:07:56 +0000
commit32beff2ff583cbabc2e88c62cd3e2074a3b75cda (patch)
treee9eb7d95f944d417feeccc8d2a7669f21076d3cd /Makefile.am
parentead7790d47b67de543b5e39ca3b307346484d3b7 (diff)
configure.ac: add --enable-tests
Allow the user to disable tests through --disable-tests, this is especially useful for example to disable gdk-pixbuf dependency Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Acked-by: Frediano Ziglio <fziglio@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 5402499..00623a1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,11 @@
NULL =
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = python_modules common tests docs
+SUBDIRS = python_modules common docs
+
+if ENABLE_TESTS
+SUBDIRS += tests
+endif
EXTRA_DIST = \
meson.build \