summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@gmail.com>2016-03-10 15:18:06 +0100
committerMarc-André Lureau <marcandre.lureau@redhat.com>2016-03-10 16:01:36 +0100
commit1cd26b87c10870ea9bfb65b4640d2e318b45aafb (patch)
treed6488289140a7082bea97ea12ab2eaa551f401e1 /Makefile.am
parentf06f699d7817354a532f091f46044720f9045887 (diff)
Revert "Remove files moved to spice-protocol"
This reverts commit 7665dcf1bb2fa0b16b3d0015b28d7f5912664c3f. Also revert the related build-sys changes to fix the build. codegen generated code depends on spice-common code (marshaller, messages etc), it makes more sense to keep the generator along this. Otherwise a newer protocol release will fail to build older projects. *.proto files are required as well, since it generates code that parent modules depend on unconditionnaly. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4d9cf59..63d7956 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,15 @@
NULL =
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = common tests
+SUBDIRS = python_modules common tests
+
+EXTRA_DIST = \
+ spice_codegen.py \
+ spice.proto \
+ spice1.proto \
+ $(NULL)
+
+DISTCLEANFILES = *.pyc
MAINTAINERCLEANFILES = \
$(srcdir)/INSTALL \