summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Peres <martin.peres@labri.fr>2013-07-26 00:43:59 -0400
committerMartin Peres <martin.peres@labri.fr>2013-07-26 00:43:59 -0400
commit6ad7c1980694a77ecb9435e42324281f91ab3d4f (patch)
tree353cb3d766cff2bbe3a53d5bd0fdb6ceffade00d /CMakeLists.txt
parentc1a15d98061125d695c347a6f168e0df90612c86 (diff)
cmake: do not install rnndb/.gitignore
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f8665848..e47f435e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,9 +23,13 @@ add_subdirectory(vdpow)
add_subdirectory(nvhw)
add_subdirectory(hwtest)
+# Get the proper list of hwdoc files (without .gitignore)
+file(GLOB_RECURSE HWDOCS_SRC hwdocs/*)
+list(REMOVE_ITEM HWDOCS_SRC ".gitignore")
+
install(DIRECTORY include/ DESTINATION include/envytools)
install(DIRECTORY rnndb DESTINATION share)
-install(DIRECTORY hwdocs DESTINATION ${DOC_PATH})
+install(FILES ${HWDOCS_SRC} DESTINATION ${DOC_PATH}/hwdocs)
install(FILES README DESTINATION ${DOC_PATH})
message("")