summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Clark <robdclark@gmail.com>2014-04-03 14:54:02 -0400
committerRob Clark <robdclark@gmail.com>2014-04-27 12:01:56 -0400
commitb241934238feedcb86c113fe3beb69a7470de02d (patch)
treed6bbbb34d9884856f4991d1a00141b39de1ae60a /configure.ac
parent4c3932620c29c91dfbbc8eb09c84efcaa7ec873e (diff)
default to stub int10 implementation on arm
There should be no reason to need a real int10 implementation on arm, and switching to stub is an easy way to fix: xf86x86emu.c: In function 'xf86Int10ExecSetup': xf86x86emu.c:56:9: error: unknown field 'xf_outb' specified in initializer xf86x86emu.c:57:9: error: unknown field 'xf_outw' specified in initializer xf86x86emu.c:58:9: error: unknown field 'xf_outl' specified in initializer which is caused by the following in compiler.h: #define outb xf_outb #define outw xf_outw #define outl xf_outl Signed-off-by: Rob Clark <robdclark@gmail.com> Acked-by: Daniel Stone <daniels@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0c8b5162d..e5387bffd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -325,6 +325,7 @@ case $host_cpu in
;;
arm*)
ARM_VIDEO=yes
+ DEFAULT_INT10="stub"
;;
i*86)
I386_VIDEO=yes