summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@neko.keithp.com>2007-07-10 21:06:51 -0700
committerKeith Packard <keithp@neko.keithp.com>2007-07-10 21:33:54 -0700
commit561989f2f0fc31e3d3bf8df978a9cb3d4c85af59 (patch)
tree1ed7b03165412534b49027907d51168e08c9a906 /Makefile.am
parente316fa59fea8b7b18cdf3a227890351a9567ec65 (diff)
Generate ChangeLog file for make dist.
Copy Makefile.am snippet which generates a complete git change history to the ChangeLog file during the distribution generation process.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f35539e49..e382d58e7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -64,7 +64,17 @@ aclocal_DATA = xorg-server.m4
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xorg-server.pc
-EXTRA_DIST = xorg-server.pc.in xorg-server.m4
+EXTRA_DIST = xorg-server.pc.in xorg-server.m4 ChangeLog autogen.sh
+
+MAINTAINERCLEANFILES=ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || \
+ (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
DIST_SUBDIRS = \
doc \