summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Gordon <bmgordon@chromium.org>2017-10-20 15:34:57 -0600
committerEric Engestrom <eric.engestrom@imgtec.com>2017-10-24 14:46:22 +0100
commitde3555f83497498201aeea111292654e95fb5bd4 (patch)
tree936f80706981e4f5ff1dfe23d99f3cbf292f49f7 /configure.ac
parent2a414c39619320c44e4d0f8f7a7609598081e2b2 (diff)
configure: Allow android as an EGL platform
I'm working on radeonsi support in the Chrome OS Android container (ARC++). Mesa in ARC++ uses autotools instead of Android.mk, but all the necessary EGL bits are there, so the existing check is too strict. Signed-off-by: Benjamin Gordon <bmgordon@chromium.org> Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index add3830f23..9aa02f55de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2410,12 +2410,13 @@ dnl Surfaceless is an alternative for the last one.
dnl
require_basic_egl() {
case "$with_platforms" in
- *drm*|*surfaceless*)
+ *drm*|*surfaceless*|*android*)
;;
*)
AC_MSG_ERROR([$1 requires one of these:
1) --with-platforms=drm (X, Wayland, offscreen rendering based on DRM)
2) --with-platforms=surfaceless (offscreen only)
+ 3) --with-platforms=android (Android only)
Recommended options: drm,x11])
;;
esac