summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2017-10-01 23:20:55 -0700
committerMatt Turner <mattst88@gmail.com>2017-10-02 19:41:22 -0700
commit74b5568978968f580b9809135198db1015bc55b7 (patch)
tree87b5ea4370812aa1f583dca52b15abcdf6f3e517 /configure.ac
parent8d02abd0feaaef28a35d89903bd534a7f27c38d7 (diff)
build: Remove HAVE_DLOPEN
Reviewed-by: Nicolai Hähnle <nicolai.haehnle@amd.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index cfc97d9f06..903a3979d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -831,9 +831,9 @@ AC_LINK_IFELSE([AC_LANG_SOURCE([[
dnl Check to see if dlopen is in default libraries (like Solaris, which
dnl has it in libc), or if libdl is needed to get it.
-AC_CHECK_FUNC([dlopen], [DEFINES="$DEFINES -DHAVE_DLOPEN"],
+AC_CHECK_FUNC([dlopen], [],
[AC_CHECK_LIB([dl], [dlopen],
- [DEFINES="$DEFINES -DHAVE_DLOPEN"; DLOPEN_LIBS="-ldl"])])
+ [DLOPEN_LIBS="-ldl"])])
AC_SUBST([DLOPEN_LIBS])
dnl Check if that library also has dladdr