summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2014-01-30 12:08:57 -0800
committerEric Anholt <eric@anholt.net>2014-01-30 12:11:24 -0800
commitf6e91a7e86c288be5e91d58e2bdb110f3c1c89ea (patch)
treebdeca302200ba868eac1e92e47bdda4e14eeb30e /configure.ac
parent12ef9dcf2d3600bcbe926c83597f9a782c5a068c (diff)
Declare a private dependency on libdl.
The new linker requires that the consumers of a library link against the libraries that that library depends on, which is supported by Libs.private. Fixes #16
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fd390de..3037c76 100644
--- a/configure.ac
+++ b/configure.ac
@@ -106,6 +106,9 @@ fi
AM_CONDITIONAL(HAS_ZNOW, test x$has_znow = xyes)
+AC_CHECK_LIB([dl], [dlopen], [DLOPEN_LIBS="-ldl"])
+AC_SUBST([DLOPEN_LIBS])
+
case $host_os in
mingw*)
# visibility flags aren't supported for windows DLLs, and the