summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2013-12-12 11:18:28 -0800
committerEric Anholt <eric@anholt.net>2013-12-12 11:39:34 -0800
commit0cfb0a044bc43245409c020e2ca34091c96283d4 (patch)
tree4aae7d9ddbc86f681b654bf1e091612394723403 /configure.ac
parent8d8334c350e8979c23bd9fe7c942693fcf76f958 (diff)
Fix most GLhandleARB warnings on OS X with a big comment in our code.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c2815b7..f1d2b0f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,6 +48,10 @@ AC_LIBTOOL_WIN32_DLL
AC_PROG_LIBTOOL
AC_SYS_LARGEFILE
+# OS X defaults to having -Wint-conversion ("warn when passing
+# uintptr_t to a void *") by default. Kill that.
+XORG_TESTSET_CFLAG(CWARNFLAGS, [-Wno-int-conversion])
+
case $host_os in
mingw*)
build_egl=no