summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2011-02-14 22:17:41 -0500
committerKristian Høgsberg <krh@bitplanet.net>2011-02-14 22:21:13 -0500
commitfcfb4e30a47a4cd2416dac210521594b489c8bfd (patch)
treee940236740627c99898ad726246226977c9d7af8 /configure.ac
parent525e4c0beae832afc2c098c1368a19ad164e1b2b (diff)
Split into a core repository that only holds the core Wayland libraries
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac57
1 files changed, 4 insertions, 53 deletions
diff --git a/configure.ac b/configure.ac
index 48b9169..34b8dbc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,48 +22,6 @@ LT_INIT
PKG_PROG_PKG_CONFIG()
PKG_CHECK_MODULES(FFI, [libffi])
-PKG_CHECK_MODULES(COMPOSITOR,
- [egl >= 7.10 glesv2 gdk-pixbuf-2.0 libudev >= 136 libdrm >= 2.4.23] pixman-1 xcb-dri2 xcb-xfixes)
-PKG_CHECK_MODULES(GLES2, [egl >= 7.10 glesv2])
-PKG_CHECK_MODULES(CLIENT, [egl >= 7.10 gl cairo >= 1.10.0 gdk-pixbuf-2.0 glib-2.0 gobject-2.0 xkbcommon])
-PKG_CHECK_MODULES(POPPLER, [poppler-glib gdk-2.0 gio-2.0],
- [have_poppler=yes], [have_poppler=no])
-AM_CONDITIONAL(HAVE_POPPLER, test "x$have_poppler" = "xyes")
-
-AC_CHECK_PROG(RSVG_CONVERT, rsvg-convert, rsvg-convert)
-AM_CONDITIONAL(HAVE_RSVG_CONVERT, test -n "$RSVG_CONVERT")
-
-AC_ARG_ENABLE(x11-compositor, [ --enable-x11-compositor],,
- enable_x11_compositor=yes)
-AM_CONDITIONAL(ENABLE_X11_COMPOSITOR, test x$enable_x11_compositor == xyes)
-if test x$enable_x11_compositor == xyes; then
- AC_DEFINE([BUILD_X11_COMPOSITOR], [1], [Build the X11 compositor])
-fi
-
-
-AC_ARG_ENABLE(drm-compositor, [ --enable-drm-compositor],,
- enable_drm_compositor=yes)
-AM_CONDITIONAL(ENABLE_DRM_COMPOSITOR, test x$enable_drm_compositor == xyes)
-if test x$enable_drm_compositor == xyes; then
- AC_DEFINE([BUILD_DRM_COMPOSITOR], [1], [Build the DRM compositor])
-fi
-
-
-AC_ARG_ENABLE(wayland-compositor, [ --enable-wayland-compositor],,
- enable_wayland_compositor=yes)
-AM_CONDITIONAL(ENABLE_WAYLAND_COMPOSITOR,
- test x$enable_wayland_compositor == xyes)
-if test x$enable_wayland_compositor == xyes; then
- AC_DEFINE([BUILD_WAYLAND_COMPOSITOR], [1],
- [Build the Wayland (nested) compositor])
-fi
-
-
-PKG_CHECK_MODULES(CAIRO_EGL, [cairo-egl],
- [have_cairo_egl=yes], [have_cairo_egl=no])
-AS_IF([test "x$have_cairo_egl" = "xyes"],
- [AC_DEFINE([HAVE_CAIRO_EGL], [1], [Have cairo-egl])])
-
if test "x$GCC" = "xyes"; then
GCC_CFLAGS="-Wall -g -Wstrict-prototypes -Wmissing-prototypes -fvisibility=hidden"
fi
@@ -80,16 +38,9 @@ AC_CHECK_LIB(expat, XML_ParserCreate, [EXPAT_LIBS="-lexpat"],
[AC_MSG_ERROR([Can't find expat library. Please install expat.])])
AC_SUBST(EXPAT_LIBS)
-# workaround a bug in xcb-dri2 generated by xcb-proto 1.6
-AC_CHECK_LIB(xcb-dri2, xcb_dri2_connect_alignment_pad, [],
- [AC_DEFINE([XCB_DRI2_CONNECT_DEVICE_NAME_BROKEN], [1],
- [Define to 1 if xcb_dri2_connect_device_name is broken])])
-
-AC_CONFIG_FILES([wayland/wayland-server.pc
- wayland/wayland-client.pc
- Makefile
+AC_CONFIG_FILES([Makefile
+ wayland-scanner.m4
wayland/Makefile
- compositor/Makefile
- clients/Makefile
- data/Makefile])
+ wayland/wayland-server.pc
+ wayland/wayland-client.pc])
AC_OUTPUT