summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Bradford <rob@linux.intel.com>2013-06-04 13:27:49 +0100
committerKristian Høgsberg <krh@bitplanet.net>2013-06-04 23:13:34 -0400
commitbc3e020475e0fc29f265c4f8029f03584bee086e (patch)
tree87cacd36902120b19141e3689c11ce60fbdaf8cf /configure.ac
parentb6930889044dcd92be5c7499e653c6cb19cddb19 (diff)
build: Add declaration checks to check for required syscall flags
The required flags are relatively new and some older enterprise distributions do not feature them. https://bugs.freedesktop.org/show_bug.cgi?id=63360
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f317a73..7f3a694 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,6 +41,17 @@ AC_SUBST(GCC_CFLAGS)
AC_CHECK_FUNCS([accept4 mkostemp])
+AC_CHECK_DECL(SFD_CLOEXEC,[],
+ [AC_MSG_ERROR("SFD_CLOEXEC is needed to compile weston")],
+ [[#include <sys/signalfd.h>]])
+AC_CHECK_DECL(TFD_CLOEXEC,[],
+ [AC_MSG_ERROR("TFD_CLOEXEC is needed to compile weston")],
+ [[#include <sys/timerfd.h>]])
+AC_CHECK_DECL(CLOCK_MONOTONIC,[],
+ [AC_MSG_ERROR("CLOCK_MONOTONIC is needed to compile weston")],
+ [[#include <time.h>]])
+AC_CHECK_HEADERS([execinfo.h])
+
AC_ARG_ENABLE([scanner],
[AC_HELP_STRING([--disable-scanner],
[Disable compilation of wayland-scanner])],