summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2011-02-13 13:00:51 -0500
committerKristian Høgsberg <krh@bitplanet.net>2011-02-13 13:26:39 -0500
commit31bd6c7ab10d4523684fa45f353b10e92f1187f4 (patch)
tree8399dfe65a681702bb1ed514f724a040b3582c71 /configure.ac
parent9c7a8cc663cb7887ba9b4499ae6e421ee6d6fef1 (diff)
Use pixman regions to reduce repainting
For now, we just use glScissor and clip to the extent of the damage region, but we can do even better by clipping the repaint to the region rectangles.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b671722..48b9169 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,7 +23,7 @@ PKG_PROG_PKG_CONFIG()
PKG_CHECK_MODULES(FFI, [libffi])
PKG_CHECK_MODULES(COMPOSITOR,
- [egl >= 7.10 glesv2 gdk-pixbuf-2.0 libudev >= 136 libdrm >= 2.4.23] xcb-dri2 xcb-xfixes)
+ [egl >= 7.10 glesv2 gdk-pixbuf-2.0 libudev >= 136 libdrm >= 2.4.23] pixman-1 xcb-dri2 xcb-xfixes)
PKG_CHECK_MODULES(GLES2, [egl >= 7.10 glesv2])
PKG_CHECK_MODULES(CLIENT, [egl >= 7.10 gl cairo >= 1.10.0 gdk-pixbuf-2.0 glib-2.0 gobject-2.0 xkbcommon])
PKG_CHECK_MODULES(POPPLER, [poppler-glib gdk-2.0 gio-2.0],