summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPekka Paalanen <ppaalanen@gmail.com>2012-03-22 11:30:35 +0200
committerKristian Høgsberg <krh@bitplanet.net>2012-03-30 09:32:24 -0400
commit0e81a0b157c7c8d7c02a8519ac56f3d601a8b287 (patch)
tree68705694b0037b1975c66dad919e06f676d7d969 /configure.ac
parent5b72fc7528aa9f7c655dd49a2227cfd1e3feeb76 (diff)
configure: add -Wextra -Wno-unused-parameter
This adds more gcc warnings that should be useful, and suppresses the unused parameter warnings that are not wanted. Most importantly, this change enables warnings about comparison between signed and unsigned. Signed-off-by: Pekka Paalanen <ppaalanen@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 094da67..194850c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,7 +23,7 @@ PKG_PROG_PKG_CONFIG()
PKG_CHECK_MODULES(FFI, [libffi])
if test "x$GCC" = "xyes"; then
- GCC_CFLAGS="-Wall -g -Wstrict-prototypes -Wmissing-prototypes -fvisibility=hidden"
+ GCC_CFLAGS="-Wall -Wextra -Wno-unused-parameter -g -Wstrict-prototypes -Wmissing-prototypes -fvisibility=hidden"
fi
AC_SUBST(GCC_CFLAGS)