summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTiago Vignatti <tiago.vignatti@intel.com>2012-10-12 20:54:45 +0300
committerKristian Høgsberg <krh@bitplanet.net>2012-10-15 13:10:08 -0400
commit008760822b973ff1f8122533787a4dadeed7e2a8 (patch)
treec185575df7ea1b058a286c698c19c2791b5dcbb1 /Makefile.am
parent96a6ee58b96afc51a78859fe6da0d9b015a68cc9 (diff)
configure: Make documentation option work in fact
Also, now doxygen is mandatory for building the documentation (looks reasonable because both man-pages and publican will need it). Signed-off-by: Tiago Vignatti <tiago.vignatti@intel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8f5f83e..306d7b3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,8 @@
-SUBDIRS = src protocol doc tests cursor
+if BUILD_DOCS
+doc_subdir = doc
+endif
+
+SUBDIRS = src protocol $(doc_subdir) tests cursor
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}