summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexander Gottwald <alexander.gottwald@s1999.tu-chemnitz.de>2005-07-05 23:01:51 +0000
committerAlexander Gottwald <alexander.gottwald@s1999.tu-chemnitz.de>2005-07-05 23:01:51 +0000
commit6ba4a2e78a73858648b5b6a39306446d519c3a75 (patch)
treec4b25a15a33cd0e9f5460738ab346015219e6291 /Makefile.am
parent71ed3ae0c696152e82a98ce2ac0fa67ce6f23464 (diff)
Add more defines for XWin DDX Make building of cfb*, afb and mfb
conditional Set FD_SETSIZE=256 on cygwin
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 21 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index acd068ee1..f07500d54 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,6 +6,18 @@ endif
if XTRAP
XTRAP_DIR=XTrap
endif
+if CFB
+CFB_DIR=cfb
+CFB16_DIR=cfb16
+CFB24_DIR=cfb24
+CFB32_DIR=cfb32
+endif
+if AFB
+AFB_DIR=afb
+endif
+if MFB
+MFB_DIR=mfb
+endif
SUBDIRS= \
include \
@@ -17,19 +29,19 @@ SUBDIRS= \
os \
randr \
render \
- Xi \
- mfb \
- xkb \
- afb \
- cfb \
- cfb16 \
- cfb24 \
- cfb32 \
+ Xi \
+ xkb \
+ $(MFB_DIR) \
+ $(AFB_DIR) \
+ $(CFB_DIR) \
+ $(CFB16_DIR) \
+ $(CFB24_DIR) \
+ $(CFB32_DIR) \
record \
xfixes \
damageext \
$(XTRAP_DIR) \
- $(COMPOSITE_DIR) \
+ $(COMPOSITE_DIR) \
hw
pkgconfigdir = $(libdir)/pkgconfig